Welcome to Zen Cart™ ...

The Zen Cart™ software is made available to you for use, additions, changes, modifications, etc. without charge, under the GNU General Public License.

While we do not charge for this software, donations are greatly appreciated each time you download a new version, to help cover the expenses of maintenance, upgrades, updates, the free support forum and the continued development of this software for your online e-commerce store.

Donations can be made at: The Zen Cart™ Team Page

We appreciate your support.
The Zen Cart™ Team

Zen Cart™ is derived from: Copyright 2003 osCommerce
This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE
and is redistributable under the GNU General Public License

This software is OSI Certified Open Source Software.
OSI Certified is a certification mark of the Open Source Initiative.

CHANGELOG - List of Changed Files

For a list of files that have been changed since v1.3.9g, see the changelog-v1-3-9h.html


For added security, Zen Cart™ comes with several .htaccess files already included in various folders to help provide protection against unwanted visitors and even against mis-use of your site in the unfortunate situation of your site being hacked. These protections prevent hackers from using your site as phishing sources.

However, for these built-in protections to work, your web hosting server administrator MUST set the AllowOverride directive in the server's apache configuration (the server's master httpd.conf file) to "All" or at least ensure it includes these parameters: 'Limit Indexes'.

ie:    AllowOverride All
or:    AllowOverride Limit Indexes    

(NOTE: You must also add "Options" if uncommenting OPTIONS directives in your .htaccess files)

Without these settings, you will likely encounter "500 Internal Server Error" messages when attempting to access various parts of your site, including perhaps the zc_install installer script.

Storeowners hosting on Windows Servers using IIS instead of Apache may need to remove the .htaccess files and rework them into suitable equivalents within your IIS configuration. See Microsoft's IIS website for specific assistance.


Inside some folders is an .htaccess file that lists certain *permitted* filetypes which may be accessed. (Anything else is blocked to prevent abuse on your site).

The side-effect of this is that if you choose to use media types that are not already listed in the *permitted* list, then your visitors will not be able to see those resources.

Thus, if you are using product images that are not in the list of permitted types in your /images/.htaccess, you will need to add those types to the list.

Similarly, if you are using certain media types in music product previews, you will need to make sure those are in your /media/.htaccess

And, if you are using filetypes for downloadable products that are not already listed in your /pub/.htaccess and /download/.htaccess you will need to add those as well.

Zen Cart™ Server Requirements

MINIMUM Requirements:
PHP 4.3.2 or higher, Apache 1.3.30 and MySQL 3.23.x or higher.

RECOMMENDED Requirements:
PHP 5.3.2 or higher, Apache 2.2 or higher and MySQL 4.1 or higher.

While Zen Cart can run on Windows/IIS servers, Linux/Apache servers are recommended for best results.

Upgrade Instructions from v1.3.9a/b/c/d/e/f/g to 1.3.9h

If you are upgrading from Zen Cart v1.3.9a or 1.3.9b or 1.3.9c or 1.3.9d or 1.3.9e or 1.3.9f or 1.3.9g, the process is simple:
- compare all the changed files with the files on your own site... and re-apply your customizations to the new files
- upload the new files (with your customizations added) to your site
- (there are no database-updates required between v1.3.9a to v1.3.9b or v1.3.9c or v1.3.9d or v1.3.9e or v1.3.9f or v1.3.9g or v1.3.9h)
- (there's no need to remove/re-install payment modules between "d" and "e" and "f" and "g" and "h")

If you are upgrading from a version prior to v1.3.9a, please follow the instructions in the "how to upgrade" documentation in the /docs folder.


It is advisable to clear your browser cache and cookies after upgrading, before attempting to access your Admin section. Old admin cookies may prevent you from logging in until you clear the cache and cookies and restart the browser.

Whats New ...

The following improvements and bugfixes are included in v1.3.9h since v1.3.9g:

  • CHANGE-74 - Fix unsanitized inputs in some forms
  • CHANGE-84 - Add security token to forms, to prevent CSRF/XSS attacks
  • CHANGE-86 - Add session cookie handling switches to Sessions configuration screen in Admin to allow server-specific customization of cookie handling
  • BUGSFORUM-1530 - HTML editing in Admin UI caused undesirable display confusion due to aggressive security protections. Removed the need for whitelisting which was introduced in v1.3.9g (custom whitelist files can be removed)
  • BUGSFORUM-1542 - Added further sanity checks to linkpoint_api module to further prevent SGS-002301 errors
  • BUGSFORUM-1548 - Fix problem with improper address matching if PayPal returns a blank address in an Express Checkout transaction
  • BUGSFORUM-1557 - Fix deprecated PayPal EC API key names
  • BUGSFORUM-1559 - Fix minor table nesting issue
  • BUGSFORUM-1561 - minor messageStack error in admin upload class
  • BUGSFORUM-1562 - Admin page for "specials" - error in displayed info
  • BUGSFORUM-1565 - Fix problem with PayPal Express Checkout where shipping wasn't recalculated if shopping cart contents were altered midway through checkout.
  • BUGSFORUM-1566 - minor fix to error message handling in admin upload class
  • BUGSFORUM-1577 - Password must contain a minimum of x characters
  • BUGSFORUM-1262 - Fix HTMLarea error message on Safari browsers.
  • Authorize.net - Updated Fraud Detection Suite filter handling
  • Minor: Updated some payment modules to have 15 instead of 10 years shown for expiry dates when entering credit card details

Zen Cart™ Copyright 2003-2010